HOME

Noch Fragen?

Frage Nummer 45927 NePe_2000

Gibt es in Excel eine Formel mit der ich die Anzahl der Zeichen in einer Zelle zählen kann? Ich find da nix!

Antworten (6)
Sallah
Formel Länge(Text) oder z.B. Länge (A4) wenn Zelle A4

Formel einfügen
Kategorie Text
Heiko Heinrich
Es gibt im Internet ein Office Forum, wo man diese Formel finden kann. (=Länge(A1)) Wenn man in der Suchmaschine den Suchbegriff "Anzahl Zeichen in Zelle zählen" eingibt, findet man einige Links zu diesem Thema. Unter anderem auch die Formel Anzahl der Zeichen in einer Zelle.In diesen Foren findet man auch noch unzählige andere Formeln für Zeichen Zählung.
Sallah
Du darfs natürlich auch hier fragen, no problem.
Felix_of_the_dark10
Am besten Sie nehmen die Länge, sprich =Länge(A1)
Angenommen in A1 steht Ihr Text, dann würde die Formel für die Anzahl der Zeichen in Feld B1 lauten :
=WENN(A1="";0;LÄNGE(A1))
Als Ansatz zum experimentieren :
Zelle C1 =WENN(LÄNGE(A1)>5;LINKS(A1;5);A1)
Zelle D1 =RECHTS(A1;LÄNGE(A1)-LÄNGE(C1))
Angenommen Sie möchten anschliessend noch den Text einer Zelle auf z.B. 100 Zeichen begrenzen, dann lautet die Formel :
Zelle A8 =LINKS(A7;100)
Sallah
Dann sollte aber auch gelten:
C5 : =(LÄNGE(B2) -LÄNGE( WECHSELN(B2;"excel";"")))/LÄNGE("excel")
D5 : =(LÄNGE(B2) -LÄNGE( WECHSELN(B2;"Excel";"")))/LÄNGE("Excel")
E5 : =(LÄNGE(B2) -LÄNGE( WECHSELN(KLEIN(B2);"excel";"")))/LÄNGE("excel")
Felix Wagner
Ja es gibt eine Formel zum Zählen der Zeichen in einer Zelle. Möchten Sie zum Beispiel die Zeichen in der Zelle A1 Zählen, so geben Sie in ein beliebiges Feld =Länge(A1) ein. Hierbei dürfen Sie auf keinen Fall das Istgleich vergessen, sonst erkennt Excel die Zelle nicht als Formel, sondern als Text an.